Excel 2004: Keyboard customization and macro warning nonsense

Posted by Pierre Igot in: Microsoft
March 21st, 2006 • 2:52 pm

Microsoft Excel 2004 really is an unbelievable piece of crap.

I am currently working on an spreadsheet (authored by someone else) in which I have to merge cells repeatedly.

So I wanted to assign a keyboard shortcut to the “Merge Cells” command, instead of having to switch to the mouse all the time.

I had already added the “Merge Cells” command to one of my toolbars. So I simply right-clicked on that button to bring the contextual menu that has the “Properties…” command:

Merge Cells button with menu

This “Properties…” command brings up a dialog box with various command-specific settings and controls, including a “Keyboard…” button that brings up the “Customize Keyboard…” dialog box with the focus directly on the command in question.

This beats having to bring up the “Customize Keyboard…” dialog box manually and then having to tediously browse through the lists of commands until you are able to locate the desired command.

So I used this to assign a keyboard shortcut to the “Merge Cells” command. I chose control-F10. Excel told me that this shortcut was already assigned to the “Full Screen” command, but I didn’t care, since I don’t use that “Full Screen” command. I instructed Excel to assign control-F10 to “Merge Cells” instead.

Or so I thought.

It worked fine for a while and I was able to use the keyboard shortcut to access the command several times in my document.

Then all of a sudden out of the blue Excel started acting up and reverted to interpreting control-F10 as the shortcut for the “Full Screen” command. In other words, insteading of merging cells, control-F10 would switch to full screen mode.

So I figured that Excel simply didn’t agree with my keyboard shortcut selection, and I tried another one, namely control-F11, which is normally assigned to a command to insert an Excel 4.0 macro into the spreadsheet (something that I am not likely to ever try in my lifetime).

Unfortunately, this too failed, and instead of merging cells, I ended up accidentally adding an Excel 4.0 macro to my document!

At that point, I quit and relaunched Excel, vaguely hoping that this would fix the problem. Unfortunately, it didn’t. But it got even worse: When I tried to open the spreadsheet I was working on at the time I changed the keyboard shortcut, Excel showed me this dialog:

Macro warning

What the hell? I tried quitting and relaunching, to no avail. I tried to follow the dialog’s recommendation and clicked on the “Disable Macros” button, only to be told that my document actually contained macros that “couldn’t be disabled.”

So I tried to open the document by enabling the macros instead, which worked, and then I tried to save the document under a new name. When I tried opening the file with the new name, I got the same warning. Grr!

It was only when I realized that Excel was actually troubled by the (empty) Excel 4.0 macro that it had itself inserted in the document that I was able to fix the problem. After the control-F11 fiasco mentioned above, my Excel document had an additional tab at the bottom next to the three tabs for the three sheets that are there by default, and that other tab was named “Macro.” It had nothing in it, of course, but that didn’t prevent Excel from acting up.

So I selected the tab and deleted it, and after that things were finally back to normal. My document no longer causes the macro warning to appear, and the control-F11 shortcut is working for merging cells.

But for how long?

With Excel, you obviously never know. And whatever you do, don’t try adding a macro to your document. You will be the author of your own document’s demise!

Comments are closed.

Leave a Reply

Comments are closed.